No axis working besides Y

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #507 Quote

    Hello there,
    I’ve started to test the GRBL code with the GRBL Universal code sender, but for some reason, the only axis working is Y. We’re currently testing with only one motor (we change the axis which the stepper and the pololu is connected when we want to test another axis) and no opto sensors/end-stop sensors and using Arduino mega 2560 with Ramps 1.4.Is there any kind of limitation that makes it unable to work without all the opto-sensors or motors connected to the ramps?If possible, could someone please send me a working GRBL Algorithm/Library ; file for all the axis?I also have some suspects that this is tied to the homing function on GRBL.
    Best Regards,Thalles Machad

    #969 Quote
    Angel LM
    Admin

    Hi Thalles,

    You are using an2560 with a Ramps 1.4, but which GRBL did you flashed to the arduino board? The original GRBL or the one I modified?
    The cpu_map_atmega2560.h file is different and maybe that’s the issue. I modified that file to work with the ControlPCB board and not with the Ramps.

    If you want to control your Thor with Ramps boards you will need 2 units. The first one for the first 3 articulations and the other one for the last 3 articulations. I did it years ago flashing the original GRBL code to the arduinos and sending a gcode to each board separately.

    Marlin could be a better option (for testing at least) as it allows you to control 5 stepper motors (X,Y,Z,E1,E2) so you can control 5 articulations with just 1 ramps.

    Hope it helps!
    Angel LM

    #971 Quote

    Hi Ángel,
    We’re currently testing with marlin. We tried to control the motors with your modified grbl, but we failed to make the steppers with the mechanical reduction work.We can’t figure out which parameters to use for these steppers.We’re also looking on the default files and we don’t have a clue on what to do with that information (generic, shapeoko, shapeoko2). ;
    Best regards, ;Thalles Machado

    #973 Quote
    Angel LM
    Admin

    Hi Thalles,

    The steppers with the mechanical reduction are working in Marlin? Could you share the model of that steppers?

    In my case, I control them in the same way I control the normal steppers, so I don’t really have a clue about what is happening in your case 🙁

    Let’s try to fix it 😉
    Angel LM

    #975 Quote

    Hi Angel,
    we tested with Marlin, but the only thing the stepper with machanical reduction does is vibrate. We tested the others and they are working fine.Did you set up micro steps for the steppers with the mechanical reduction?We already checked for problems on the wiring of the steppers several times, it seems to not the the problem in this case.
    Best regards;Thalles Machado ;

    #977 Quote
    Angel LM
    Admin

    Hi Thalles,

    Yes, I used 16 microsteps for every stepper driver.
    I’m sure that you already did it but, just to be sure:

    • Have you tried with other stepper driver?
    • Have you tried to move a normal stepper with the same driver that is not moving the stepper with the mechanical reduction?
    • Have you tried to adjust the current of the driver?
    • Have you checked that the coils of the motor are ok? And the wires of the coils are well placed: A1-A2-B1-B2

    Tell me if you already have checked this or you are not sure about how to check something!

    Best regards,
    Angel LM

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.