Motors Don’t Work Simultaneously and Overheat

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1980 Quote
    Claudio
    Participant

    Hi Thor Community,

    I’m Claudio and I am testing the steppers motors of Thor. I have connected them to the board and I am able to control every single motor on its own. The problem I cannot solve though, is that when I connect a specific motor (Art 5) to the board and try to make it work together with the others they don’t respond to the commands launched on Asgard. I also tried connecting this “problematic” Motor to a different Stepper Driver and the result is the same. The other motors run correctly also simultaneously as long as the Motor of Art 5 is not connected.

    Another issue that I don’t quite grasp the reason for is the overheating of the motors. The overheating occurs when they are connected even if no command has been launched.

    As of now I’m kind of lost in pinpointing the problem, since the issues seem to be more than one. Do you have any guesses what could cause the issue?

    Extra Info:
    My PCB version is the v1.0, could it be the problem?

    Thank you in advance,
    Claudio

    #1981 Quote
    Angel LM
    Admin

    Hi Claudio, let’s see if we can solve the problem together!

    First of all, you say that your PCB version is the v1.0, do you mean the two-sided PCB or the one-side PCB? It’s my fault for naming them both the same, sorry for the confusion!

    Looking at your case, I think that the problem could be one of the following four:

    1. Broken Stepper Motor: Not very likely but sometimes happen. If you already have tested that motor switching it with another one and worked, you can discard this possibility.
    2. PCB traces fault: Highly Unlikely in the two-sided PCB, but likely in the one-sided one. Maybe the power traces that send the signals to the 5th motor are short-circuited or cut. You can test it with a multimeter in continuity mode.
    3. Bad component welding. Likely. If any component has not been properly welded to the PCB it may cause issues. In your case, you should check only the weldings related to the 5th motor (pins, resistor, capacitor).
    4. Misconfigured/Faulty Stepper driver. Very likely, the problem is almost certainly to be found here. Switch the stepper driver of the 5th motor with another one of the PCB which you know that works. If that is the problem, the driver could be broken or misconfigured. Drivers usually have a potentiometer build in the top which regulates the amount of current supplied to the motor. If it’s set too low, the motor will not receive enough energy to move (but it won’t cause other motors to stop, so I guess is not your case).

    Regarding the motors overheating, it’s related to point 4. When the robot is Idle, it has to hold the motors position, blocking them. If it didn’t, it would fall under its own weight. This lockout causes the motor to consume energy, warming up in the process. There are two things that you can do to try to avoid them to overheat: Cooling (that’s why I placed fans in the design) and tuning the stepper drivers to provide enough current to move the motors but not more.

    Keep us posted on your progress! 🙂

    #1986 Quote
    Claudio
    Participant

    Good Morning Angel and thanks for the very quick response!

    So I tested the motors a bit more to further describe the problems encountered.
    The problem does not stem from motor number 5 specifically, but occurs whenever 5 or more motors are plugged together and are supposed to work simultaneously. If the motors plugged, no matter which ones, are 4 or less they function properly together.
    Also the problem does not depend on the specific stepper driver to which I connect the 5th motor, I tested different configurations in which the 5th stepper plugged was always different and I always got the same result.

    I have also noticed that when 5 or more run simultaneously just one works fine. To be more precise, they all start moving at the first command given and then they stop and don’t start again at the next command, except for the one working fine. The motor working correctly changes depending on which ones of the seven motors are plugged.

    I also tested your points:
    1. It’s not the case, since each motor functions properly if plugged in on its own.
    2. It’s not the case, since the problem is unrelated to motor number 5 specifically.
    3. It could be the case. I am not an expert and this was the first time welding components, but in general each motor works correctly if plugged in on its own, so I don’t think I messed up on this (hopefully).
    4. It should not the case. The drivers control the motors correctly if they are controlled one by one. The potentiometer regulation could be a solution and I will further test the different settings.

    The problem seems to be related to the powering of the board.
    We are using:
    – a 12Volts, 10 Ampere power supply to power the PCB Board.
    – the USB cable (5V) to power the Arduino
    These should be the only power supplies needed, right?

    Since I didn’t find the fuse you suggested on aliexpress (MF-R700) I bought a JK30-250, being quite inexperienced I thought the difference was not that big and now checking the datasheet the Hold and Trip Current of our model (I_trip=5A; I_hold=2.5A) are sensibly lower the the suggested one (I_trip=7A; I_hold=14A).
    We also measure a quite consistent voltage drop across the fuse instead of close to no voltage drop (the resistance of the fuse is higher in our model than the suggested one). Could the fuse be the problem?

    Thanks again for the time and the great project 🙂

    #1987 Quote
    Angel LM
    Admin

    Hi Claudio!

    What a great investigation you have done!
    From what you say, everything points to the fuse.

    ITrip current is the minimum current required to interrupt current flow through the circuit at +23 °C. At this current level, the PTC resettable fuse is heated sufficiently to switch into a high-resistance state.
    IHold current is the maximum current the PTC fuse can sustain for long periods of time (4 hours or longer) at +23 °C without tripping.

    Your fuse is setting the motors power circuit to 5A maximum instead of 7A. If you used the Stepper Online motors, each one draws slightly less than 1Amp. As the robot has 7 motors, the circuit that powers the motors need about 7Amps. These are all approximations, depending on the model of motor you have used there may be slight variations in the total amperage needed.

    If you don’t find a PTC resettable fuse of 7A you can use a normal fuse of 7A. It would be harder to change if it breaks, but will do the job.

    Hope it helps!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.