Limit-switches doesn’t work in grbl

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #519 Quote
    Angel LM
    Admin

    Hi there!

    I’m developing a software for a project similar to the Thor. I’m using GRBL firmware. I have started from steppers connection and them work correctly. But, when I connect optical limit-switches to Arduino’s Mega 2560 pins, written in cpu_map_atmega2560.h file these limit-switches don’t work. So, perhaps, somebody has a similar problem with limit-switches or knows, how to solve it?

    #1903 Quote
    EleKoPhi
    Participant

    Hi Angel LM,

    currently I am facing two problems with the Limit Switches.
    First, one layer of 3D Print is not dense enough to trigger the switches properly -> I had to put the whole arm apart, but after a short Fusion session, I could design more dense onto discs.

    Now I try to run the homing command, but by now without success 🙁
    Any idea how to fix this?
    Running $H only ends in a alarm.
    Running G28 moves the stepper for A for around 360 degree, but also after that the system stops.

    If you have any hints, I would be pretty thankful 🙂
    As long I read the code and try to understand the implementation for homing.

    Regards
    Philipp

    #1917 Quote
    Angel LM
    Admin

    Hi EleKoPhi!

    Could you please share your $$ settings? To see the these settings just send $$ via Serial to the Arduino and it should send them back to you.

    #1919 Quote
    EleKoPhi
    Participant

    Hi Angel LM,
    I had to invert the limit switches.
    After doing so, everything worked fine.

    Last remaining issue now, is the correct control of Art5 and Art6.
    But i think this should be solvable 😀

    For the 1. tests, I modified the code of Asgard to run Thor as expected.

    #1920 Quote
    Angel LM
    Admin

    I’m glad you found the solution 😉
    If you have any other questions, feel free to ask!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.