A question about Asgard.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #503 Quote

    Hi! I have a question about Asgard. When I want that the robot moves one degree, it moves 90 degrees. Is there any way to config Asgard?Best regards . ;Marta.

    #949 Quote
    Angel LM
    Admin

    Hi Marta!

    Could you post step by step what are you doing? Or maybe a video? I tested Asgard about a month ago and I didn’t found that issue.

    Best regards,
    Angel LM

    #951 Quote

    Hi, Angel
    I will try to explain what Marta says in the first message.We downloaded Thor firmware and flashed it into an Arduino Mega following instructions in GRBL page:https://github.com/grbl/grbl/wiki/Compiling-Grbl
    Then installed in a laptop Python 3.6.5 with PySerial and PyQt5 libraries.Connected Arduino to laptop with a USB cable, opened Asgard and connected to the robot. Then, if we click on axis 1 or 2 adding 1º and pressing ‘Go’ the motors run about 90º.At this moment we do not have the electronics board yet, and we connected Arduino Mega to A4988 drivers directly using a proto board (just for testing purposes) We have connected 2 of them so far, using the pins declared in the cpu mapping file from the firmware. But as far as I know this shouldn’t be altering the way it works.Any idea?
    Thank youRafael

    #953 Quote
    Angel LM
    Admin

    Hi Raphael & Marta,

    I think that I know how to solve this. Have you modified the $ parameters? I don’t remember if the default parameters are the correct ones, I’ll mark it to check it later.

    I suppose that you didn’t modify this parameters, right? Here are my current settings. You can check what these parameters mean in this post of the original GRBL wiki.
    Connect the board to Asgard and send the command “$$” through the Console section to see your parameters. If them are different to mine, you will have to modify them.
    To change them just type the parameter and send it. For example, sending “$100=44.500” will change the Art1’s steps/mm parameter to 44.5

    Hope it helps!
    Angel LM

    #955 Quote

    Here’s my STEPS_PER_MM section from the defaults/defaults_generic.h file:

    ; ;// In here we are interpreting MM as degrees of rotation

    ; #define STEPS_PER_DEGREE(motor_steps, micro_steps, reduction)

    ; ; ; ; ((motor_steps * micro_steps * reduction) / 360.0)

    ; #define DEFAULT_A_STEPS_PER_MM STEPS_PER_DEGREE(200., 32., 5.)

    ; #define DEFAULT_B_STEPS_PER_MM STEPS_PER_DEGREE((200.*(5+2./11.)), 32., 5.)

    ; #define DEFAULT_C_STEPS_PER_MM STEPS_PER_DEGREE((200.*(5+2./11.)), 32., 5.)

    ; #define DEFAULT_D_STEPS_PER_MM STEPS_PER_DEGREE((200.*(5+2./11.)), 32., 77./13.5)

    ; #define DEFAULT_E_STEPS_PER_MM STEPS_PER_DEGREE(200., 32, 2.)

    ; #define DEFAULT_F_STEPS_PER_MM STEPS_PER_DEGREE(200., 32, 2.)

    ; #define DEFAULT_G_STEPS_PER_MM STEPS_PER_DEGREE(200., 32, 2.)

    It takes into account the gear reduction in the axis, the steps per revolution of the motor and the micro steps setting of the driver. Currently all my motor drivers are set to 32 microsteps per step.

    #957 Quote

    Thank you both, Angel and Drew.Certainly we did not change any parameter, just downloaded the firmware and flashed ‘as is’ to the Arduino. Now we can tune the axis movements.
    Rafael

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.